Service Product Update

Scheduled for Jun 15, 06:00 - 07:00 CEST

Scheduled

Announcing a service release of the Cirrus platform containing the following bug fixes and minor improvements in the [Eu-prem] region:

Improvement
- Added section title to API [GetResults] response (CR-25532)
- Proctorio: Implemented the Proctorio “Observe” code to enhance logging integration with Cirrus (CR-25159)
- Added a role permission to control access to the Archive button for markers in the Assess tab. (CR-25562)
- Added support for Match item types in candidate delivery (CR-24670)
- Added the ReadSpeaker field to “Print Key Codes” (CR-25536)
- Improved candidate name synchronization between Proctorio and Cirrus in the gradebook. (CR-25119)
- Improved webhook handling for republished results. (CR-25119)

Bugfixes
- Fixed an issue where item exports excluded some media elements. (CR-25650)
- Fixed an issue where pulling candidate results could result in a different question order in the reports. (CR-25663)
- Simplified Blueprint: fixed an issue where checkbox overlaps collection name in selection popup (CR-25730)
- Fixed an issue where Blueprint random selection could still deliver withdrawn questions if taxonomies had been removed from the item prior to withdrawal and after the assessment was published (CR-25739)
- Fixed an issue where users could not open the Insights tab despite having permissions for both Insights and Reports. (CR-25777)
- Fixed an issue where legacy schedules appeared as Unmatched in the Proctorio gradebook. (CR-25708)
- Fixed an issue where the Edit Learning Objectives Repository icon was not displayed. (CR-25745)

For more details please visit the Cirrus Release Notes page.

Time of release per hosted region:
EU Premium: 06:00 CEST (05:00/04:00 UTC)
Posted Jun 10, 2026 - 09:34 CEST
This scheduled maintenance affects: EU Premium Assessment Management (Dublin) (Scheduling (EU Premium), Marking (EU Premium), Authoring - Library/Assessments (EU Premium), Administration (EU Premium), Auxiliary - Services (EU Premium)) and EU Premium Candidate Delivery (Dublin) (Candidate Delivery incl Proctoring API (EU Premium), Single Sign-On SAML 2.0 / LTI (EU Premium), Invigilation (EU Premium)).